0%

Prime Distance


题目链接:VJ(private) [POJ]


Prime Distance

题目描述

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

输入:

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

输出:

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

样例输入1

2 17
14 17

样例输出1

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

解释

题目的意思是寻找区间内距离最小的相邻素数对,和距离最大的相邻素数对。

由于区间大小|U - L|限制在1e6以下,考虑使用区间筛。先筛出1~50000之间的素数,然后用这些素数筛掉区间内的合数,遍历一次区间,将素数取出并储存到vector中,计算相邻素数的距离最大最小值。

代码部分

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
#include<iostream>
#include<algorithm>
#include<cmath>
#include<vector>
#include<cstring>
#define int long long
using namespace std;
int prime[1020000];
bool f[1020000];
bool sh[1002000];
int cnt;
signed main()
{
f[1]=true;
for (int i=2;i<=50000;i++) {
if (!f[i]) prime[++cnt]=i;
for (int j=1;j<=cnt&&i*prime[j]<=50000;j++) {
f[i*prime[j]]=true;
if (i%prime[j]==0) break;
}
}
int l,r;
while (~scanf("%lld%lld",&l,&r)) {
memset(sh,0,sizeof(sh));
if (l==1) l++;
for (int i=1;i<=cnt;i++)
for (int j=max((l+prime[i]-1)/prime[i]*prime[i],2*prime[i]);j<=r;j+=prime[i])
sh[j-l]=true;
vector<int> vec;
for (int i=l;i<=r;i++)
if (!sh[i-l]) vec.push_back(i);
if (vec.size()<=1) printf("There are no adjacent primes.\n");
else {
int prev=vec[0];
int mi=1e9,ma=-1;
pair<int,int> p1,p2;
for (int i=1;i<vec.size();i++) {
int d=vec[i]-prev;
if (d<mi) {
mi=d;
p1.first=prev;
p1.second=vec[i];
}
if (d>ma) {
ma=d;
p2.first=prev;
p2.second=vec[i];
}
prev=vec[i];
}
printf("%lld,%lld are closest, %lld,%lld are most distant.\n",p1.first,p1.second,p2.first,p2.second);
}
}
return 0;
}
谢谢你,秋刀鱼今天有吃的了!!!